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Supplement Manual 
 
This is a supplement manual describing the new features of Autostar Envisage 
version 4.0. The First part of this manual describes the detailed usage of Drizzle as 
well as all other new features of the software. The Second part of this manual 
describes the new Drizzle feature, what it is, and the basic settings. 

Autostar Envisage V4.0  
 
If you are a first time user you should read the basic manual located on the CD 
called “Meade Deep Sky Imager: The Basics”.  
 
Along with Drizzle there are other new features to the software. They are : 
 

• Multiple Imager Operation. Envisage will now support any number of DSI’s 
and one LPI. You can now use a separate guide scope and DSI as well as 
have one for prime focus and wide field. Any of the imagers can be selected 
for guiding. The only limitation is computer speed and memory. A 2Ghz 
machine with 512 Meg of memory can easily run 3 DSI’s. 

 
• Change Stretch on Completed Images. When an image is completed you can 

now alter the histogram stretch values and save them in the final image. Just 
pull down the file->save menu and the image will be saved in the current file 
time. You can also change the file type in Save Proc… and then save again in 
the new type. 

 
• Image Files imager type. You can now rerun images through Drizzle or shift 

and combine by using the Image Files tab. simply use the Add button and 
browse to the files you want to use and select them in the order you want. 
Then click on the first file in the list and it will appear in the corresponding 
Image File tab like a live image from a camera. Draw a box around one or 
two stars if you want de-rotation and press the start button. The image will 
start building and automatically stop when all the file images have been 
processed. It is recommended that the file type FITS3P be used for the image 
files because you will get the full 16 bits from the DSI.  

 

Detailed Instructions 

If you were running a previous version of the software it is recommended that you 
delete all your old dark frames. Do this with windows explorer, the default directory 
is C:\Meade Images\Darks. 
 

Imager Naming 
The new software will prompt you to name your Deep Sky Imager the first time you 
run Envisage with the imager plugged in. Keep the name short and descriptive, this 
name will stay with that imager even on a different computer. The name is used to 
identify the imager when using multiple imagers. It is also used for dark frames. If 
you have more than one imager it is important to give a unique name to each of 
them. You can change the name in the “Cntrl” dialog when using the Pro or the Color 
dialog when using the original Deep Sky Imager. 
 



Imager Tabs 

 
 
There is now an imager tab for each imager connected to the computer. The tab 
name is the same as the imager name and when it is selected the corresponding live 
tab with the same name will be selected automatically. When a live tab is selected 
then the corresponding imager tab will be selected also. There is an extra imager tab 
called “Image Files” this is a virtual imager that can be loaded with files and then 
those images can be sent through the Drizzle process as though they came from the 
imager. This way you can re run the drizzle process with new settings for different 
results. 
 

Drizzle Tutorial 
The following tutorial assumes that you have the imager on the telescope pointed at 
a Deep Sky object properly focused and that dark frames have been taken up to the 
longest desired exposure time. 
 
Recommended settings 

File Type -> FITS3P 

Save Options -> Save All Uncombined Images 

The above settings are highly recommended. FITS3P will save the full dynamic range 
of the imager and “Save All…” will allow you to run the images back through drizzle 
offline allowing you to try different settings. These setting are found by pressing the 
Save Proc… button on the imager tab.  

Select “Drizzle” from the “Image Process” dropdown menu. 

Enter a name in the Object Name box. 

Set Min Quality and Evaluation Count as desired. 

Press the Settings button see the Drizzle Resolutions section of this 
document for a description of these settings. 

These settings are not critical if you used the recommended settings above because 
you will be able run the images back through drizzle off line. 

Start autotracking 

Follow the directions in the manual on page 31 and set up your Meade Telescope for 
autotracking/Guiding. Be sure the Imager pull down in the Telescope tab is set to the 
imager you are using for drizzle. The imagers are identified by name. 

Select 2 stars 
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The first star selected will be the shift star this is the position that will be shifted for 
subsequent images. This is also the star that will be used for telescope tracking. The 
second star is to determine the rotation angle from the first star. It is important to 
pick stars that are close to the center. Keep the selection within the middle third of 
the image, this way the telescope control will have maximum shift space. The 
telescope control will not shift the selected stars out of the image. When you run the 
images off line you can select different stars. If your telescope is polar mounted and 
well aligned you can use a single star, this will give you the maximum field of view 
possible. 

Press Start 

Envisage will create a new tab and put the drizzled image there. Be patient, 
depending on your drizzle settings and the speed of your computer it may take 20-
30 seconds after the count down for the first image to appear. The image may be 
bigger than your screen, in this case scroll bars will appear on the right and bottom. 

Telescope Tracking 

 
If you select the live image you will see your selected stars and a yellow circle with a 
cross. This is the target position. If your star was on the yellow cross when Start was 
pressed then the yellow cross will be in the upper right corner. Once the star reaches 
the first target position the yellow cross will move to the lower right corner. The 
target position will move to the next position each time the selected star reaches it. 
The next position is the lower left corner and the last position is the upper left 
corner. Once the star reaches the last position imaging will stop. But the telescope 
will continue to track on the last position. During imaging you can change the target 
position by pressing the “Set Target” button and then clicking on the desired target 
position on the live image. 

Final Stretch 

Once the image is complete you can touch up the histogram stretch and shadow 
enhance settings and then save the final result by selecting File->Save from the 
menu. 
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Offline Processing 
A great new feature of Autostar Envisage 4.0 is the ability to run your images back 
through the Drizzle process. To do this bring up the program without the imager 
plugged in, this is in order to lighten the load on your computer. You will then see 
the “Image Files” tab on the top. 

Add images 

Press the Add button in the Image Files tab on the top. The familiar Open dialog will 
appear. Navigate to the directory where the images are. Select the first image of the 
sequence and then scroll to the last image. Hold the shift key down and click on the 
last image. All the filenames from the first to the last should be selected. Now press 
Open. After a few seconds the files should appear in the “file name” list box. 
 
Select images 
 
Select the first image in the list and after a few seconds it should appear in the live 
display. You can use the arrow keys and go up an down the list and the image will 
appear. Inspect each image and click on the Remove button to take the bad images 
out of the list. This will not delete the image from your hard drive.  
 
File Type -> (what ever you want your final image type to be) 

This setting is up to you. The FITS file types will save the full dynamic range but the 
others are more user friendly. 

Save Options -> Normal 

This is the only setting that is valid, the other settings are ignored. 

Select “Drizzle” from the “Image Process” dropdown menu. 

Enter a name in the Object Name box. 

Set Min Quality and Evaluation Count to 0 and 1 respectively. 

With these settings every image will be used in the final composite image. This is 
acceptable because you have eliminated all the bad images in a prior step. 

Press the Settings button see the Drizzle Resolutions section and the 
sections following it for a description of these settings. 

These settings can be experimented with each time you re-run the process. 

Select 2 stars 

Click on the first file and then select the tracking stars. They don’t have to be the 
same ones selected when the images were taken. After the selection you can use the 
arrow down key to check the tracking of the 2 stars. 

Press Start 

Envisage will create a new tab and put the drizzled image there. Be patient, 
depending on your drizzle settings and the speed of your computer it may take 20-
30 seconds for the first image to appear. The image may be bigger than your screen, 
in this case scroll bars will appear on the right and bottom. The current file name is 
displayed in the status box below the drizzle settings. The system will stop when all 
the files have been processed. 



Final Stretch 

 

Once the image is complete you can touch up the histogram stretch and shadow 
enhance settings and then save the final result by selecting File->Save from the 
menu. The file will always be saved to your default image directory. If you want to 
save in a different format then press the Save Proc… button and set the file type 
then select File->Save from the menu. 

 
Stretch any file 
By selecting File->Open you can load any image file and perform a histogram stretch and 
shadow enhance(gamma) and then save the file in the currently selected file type by 
selecting File->Save. The file is always saved in the default image directory which is 
C:\Meade Images by default. 
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Drizzle, Detailed Description 
 
Developed by NASA for the Hubble Space Telescope, Drizzle has features that can 
dramatically increase the resolution and field of view of the Deep Sky Imager’s CCD 
chip. When the object being imaged would normally call for a bigger chip camera, 
the astrophotographer can enable the Drizzle feature, which can produce and 
effective 4.9 mega pixel camera from the Deep Sky Imager's 640x480 CCD chip, but 
only with Meade AutoStar controlled telescopes. It may seem that we are 
exaggerating, so here are the numbers: If a user selects Drizzle and inputs the value 
of 2 in the Drizzle 'Extended View' setting (effectively making a 2x2 mosaic), and a 
value of 2 in the 'Drizzle Resolution' (which takes multiple undersampled dithered 
shots of the object and reconstructs the image at higher resolution), they will end up 
with a picture that is 2560 pixels by 1920 pixels or 4,915,200 pixels. The 
uncompressed RAM file (in FITS format) will be approximately 10 megabytes. Drizzle 
is not simply enlarging the image as in interpolation. We move the telescope which in 
turn moves the image across the CCD sensor to perform seamless precision mosaics.  

Below is a screen shot of Deep Sky Imager's image capture software called 'AutoStar 
Envisage' with the Drizzle Settings dialog box opened: 

 

In the Drizzle Settings dialog box you have three options, 'Drizzle Resolution', 
'Extended View', and 'Pixel Fraction'.  Here is what happens as you change each 
setting: 
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Drizzle Resolution: 

 

By increasing the Drizzle Resolution number (maximum value 2), the image 
resolution is higher creating bigger image scale. It looks like the image is simply 
enlarged, but in fact by taking multiple undersampled dithered shots of the object it 
reconstructs the image at higher resolution. Notice the Drizzle Size increase from 
640x480 to 1248x936, and the final image size being 1248, 936. To accomplish this 
increase in resolution, we move the AutoStar controlled telescope a small amount 
and take an image, again and again reading out fractions of each pixel and then 
reconstructing the image.  

Extended View: 

 

By increasing the value to a maximum of 2 (effectively making a 2x2 mosaic) Here 
we move the telescope in small precision movements, pause to take an image, and 
then repeating the action to make a seamless mosaic. This increases the true field of 
view of the image. Notice the outer frame has increased showing the effective field 
coverage and the file size has changed from 640, 480 to 1280, 960 
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Pixel Fractions:  

 
By adjusting the Pixel Fraction size to a value smaller than 1 (minimum setting is 
.20), it sets the size of the pixel fraction that is downloaded from each pixel as the 
exposure is made. Using a smaller pixel fraction will increase the image resolution. 
While the final image size does not change with finer settings, the final image will be 
sharper. See the diagram with the smaller blue pixel fraction within each single pixel 
outlined in red in the illustration below: 
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Field De-Rotation:  

 

Instead of just tracking and stacking images by following the movements of one star, 
the Deep Sky Imager's Envisage Software with Drizzle will track and stack images 
locked on two stars, and can correct for image rotation that occurs if the telescope is 
tracking in the Altazimuth configuration, or in a roughly polar aligned telescope. 
Using this feature, you can do a quick alignment of your Meade telescope in Altaz, 
turn on the Deep Sky Imager, select Drizzle, and draw a box around each of two 
stars in the field. The resulting image will not show rotational star trails. 
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